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Introduction 
This manual is divided into 2 parts.  

• Part A for the installation of BrainWave and  
• Part B for the installation of BrainWaveSO (software-only version of BrainWave).   

Please go to the appropriate Part for the version of BrainWave you are installing.  Note:  You 
CANNOT have both versions of BrainWave installed.  If you currently have a version of 
BrainWave installed be sure to run the uninstall script first (see Part B, section II, step 2). 

The BrainWave system consists of the 3 major components. 

• Primary user interface for scan control, processing and visualization software (on the 
Advantage Workstation),  

• Stimulus presentation and paradigm development software (on the Stimulus PC)  
• Stimulus presentation hardware (visual, audio and response button hardware - see hardware 

installation documentation). 

The BrainWaveSO system (software-only version of BrainWave) has 1 component. 

•  Primary user interface for scan control, processing and visualization software (on the 
Advantage Workstation),  

IMPORTANT NOTE:  If you are installing BrainWave or BrainWaveSO over an existing 
version of BrainWaveSO please see Part B Section II-C �BrainWaveSO Save / Restore System 
Information� to save the current user defined paradigms otherwise they will be lost. 

Supported Configurations 
The following tables show MR Scanner, Advantage Workstation and RTIP option software pre-
requisites for BrainWave and BrainWaveSO option installation. 

Scanner Software AW 
Software 

RTIP 
Software 

BrainWave Software 

cnv4.283B_M4_0140.c 
+ protocols patch 2328352 rev 1 
+ Patch_CNV4_M4_08 / RTIP 
020529 

AW 4.0.5 2271261-5 2307843-2 BrainWave CD 
2303343-6 NT Recovery Disk 

9.1_M3 or later AW 4.0.5 2271261-7 2307843-2 BrainWave CD 
2303343-6 NT Recovery Disk 

vh3_M3 or later (3T Eclipse) AW 4.0.5 2271261-7 2307843-2 BrainWave CD 
2303343-6 NT Recovery Disk 

10.0_M4 or later (MGD/Excite) AW 4.0.5 2271261-7 2307843-2 BrainWave CD 
2303343-6 NT Recovery Disk 
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Scanner Software AW 
Software 

RTIP 
Software 

BrainWaveSO Software 

cnv4.283B_M4_0140.c 
+ protocols patch 2328352 rev 1 
+ Patch_CNV4_M4_08 / RTIP 
020529 

AW 4.0.5 2271261-5 2337089 BrainWaveSO CD 

9.1_M3 or later AW 4.0.5 2271261-7 2337089 BrainWaveSO CD 
vh3_M3 or later (3T Eclipse) AW 4.0.5 2271261-7 2337089 BrainWaveSO CD 
10.0_M4 or later (MGD/Excite) AW 4.0.5 2271261-7 2337089 BrainWaveSO CD 
 

Required information prior to the installation process: 
! IP address and netmask to be used with the Stimulus PC (Microsoft 

Windows NT workstation - NeuroActivator Machine). 

! IP address and host name of the GE Advantage Workstation 4.0 

! BrainWave license key, AW workstation 

! NeuroActivator research version license key, NT workstation (paradigm 
editing) 

Optional Information and Equipment: 
! Root password for the AW workstation (required for printer 

setup/installation) 

! Color Postscript printer 

Organization of the Instructions in this Manual 
You will find all important words in bold for your convenience.  This document is formatted into 
two columns whereby experienced users can quickly reference the key words to the left and new 
users of this manual can get detailed step instructions on the right side.   These columns are thus 
labeled Advanced Users and New Users. 
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Part A - BrainWave Installation 

I. Part A - Introduction 
The following steps outline the complete installation procedure for BrainWave software.  Note 
that the installation of stimulus PC software can normally be skipped as this is performed in 
manufacturing prior to customer shipment. 

I. Stimulus PC operating system software load from cold (normally can be skipped during 
initial installation) 

II. Stimulus PC application software load from cold (again, can normally be skipped) 
• Load and start PC virtual communications software (VNC) 
• Load and start BrainWave stimulus presentation and paradigm development software 

(Sensor Systems' "NeuroActivator"). 

III. Stimulus PC site specific configuration. 

IV. Advantage Workstation BrainWave software load and configuration. 

V. Optional Postscript printer setup. 

Section II - A
NT 4.0  SP 5 Installation

(factory pre-load or
on-site disk load)

Stimulus PC Load from Cold

Section IV -  A,B
GE AW BrainWave Installation

and Configuration on Solaris

Section V
PostScript Printer Setup

Section III - A,B
NT TCP\IP on-site settings,

NeuroActivator Configuration

Section II - B,C
VNC & NeuroActivator

Installation

On-site Configuration
By GE Field Engineer
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Stimulus PC Load from Cold  
A. Windows NT 4.0 SP �6 Installation 

The Windows NT software is preloaded at the factory or can be loaded on-site from CD if 
needed.  DO NOT change the display settings from 800x600, 256 colors.  This section is only 
required if a reload is needed.  For new installations, start with Section III �On- Site 
Configuration�. 
Advanced Users  New Users 

Insert �NT 
Recovery Disk for 
BrainWave Option� 
CD 

1. Insert the �NT Recovery Disk for BrainWave Option� CD into the NT 
workstation�s CD-ROM drive.  (GE part number 2303343-6) 

Start -> Shutdown 
(w/ auto restart) 

2. Shutdown the PC with automatic restart selected. 

Autoload 3. The system will auto-boot from the CD and load the software.  Wait a 
few minutes until the following message appears, �The software 
installation is complete.  Please remove the CD and reboot.� 

Remove CD 4. Remove the CD from the CD-ROM drive. 

CTRL-ALT-DEL 5. Press the CTRL-ALT-DEL keys simultaneously to reboot the PC.  The 
PC will boot all the way to the standard start screen with no need for 
any additional operator intervention (i.e. no login required). 

  

B. VNC Installation 

Here we begin the installation of the VNC software from the BrainWave v 1.x CD ROM. 

Advanced Users  New Users 

Insert BrainWave 
v. 1.x CD 

1. Insert the BrainWave v. 1.x CD into the NT workstation�s CD-ROM  
drive. 

Select VNC 2.   Use NT Explorer to go to <CDROM drive>:/VNC 

Setup.exe 3.   Double click the Setup.exe (or �Setup�) icon. 

Ok 4.   Click OK in the warning message dialog box. 

Next 5.   Click Next in the Welcome dialog box. 

Yes 6.   Click Yes in the SLA dialog box. 

Next 7.   Click Next.  Leave the default destination folder. 

Next 8.   Click Next.  Leave the default Program Folder entry. 

Finish 9.   Click Finish.  The system may automatically reboot at this point. 
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Install WinVNC 
Service 

10. Start -> Programs -> VNC -> Administrative Tools -> Install   
WinVNC Service  

Ok 11. Click the �Ok� in the confirmation of service installation box. 

Start WinVNC 

Service 

12.   Select from the NT taskbar: Start -> Programs -> VNC -> 
Administrative Tools -> Start WinVNC Service. (If you get an error, 
return to step 10 and reinstall.) 

Ok 13.   Click OK in the Warning dialog box. 

Password = 
neuroactivator 

14.   Enter neuroactivator in the password field. 
  (Caution:  You must use this password.) 

Ok 15.   Click Ok. 

 

C. NeuroActivator Installation for Windows NT 4.0 (SP- 6) 

Stimulus Display Module (Window NT workstation).  Note:  VNC should be installed prior to 
installing NeuroActivator. 

Advanced Users  New Users 

Locate NeuroActivator 
on CD drive  

1.    Continue with installation of NeuroActivator (from Section II-C, 
the BrainWave CD-ROM should be in the computer, if not load 
the CD).  Use NT Explorer to go to <CDROM 
drive>:/NeuroActivator (e.g. E:/NeuroActivator). 

Double click 

Setup or Setup.exe 

2.    In the NeuroActivator folder, you should see an icon labeled 
Setup or Setup.exe.  Double click on this icon.  This launches 
the NeuroActivator Installation Wizard. 

Next 3.    Quickly read the material in the first page of the Installation 
Wizard, then click on the Next button at the page bottom.  

Next 4.    The next page allows you to choose the folder into which 
NeuroActivator will be installed.  Unless there are overriding 
reasons, you should accept the default location, C:\Program 
Files\Sensor Systems, Inc.\NeuroActivator 1.x.  Then click on 
the Next button. 

Select all components 

Next 

Next 

5.    The next page allows you to choose components to install.  For a 
new installation of NeuroActivator, select all components in the 
Select Components menu in order to ensure installation of the 
complete software (this is the default).  Then click on the Next 
button and the second Next button to proceed with the 
installation.  A status bar will fill from 0% to 100% as 
installation runs to completion. 
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Finish 6.    In the final page click on the Finish button to exit the 
Installation Wizard. 

Activate Research 
Version 

7. Activate the Research Version (paradigm editor).  Use NT 
Explorer to go to the location where NeuroActivator was 
installed.  Under a standard installation this should be 
C:\ProgramFiles\Sensor Systems, Inc.\NeuroActivator 1.x.   

Double click 
NeuroActivator_res.ex
e 

8. Launch the research version of NeuroActivator by double 
clicking on NeuroActivator_res.exe. 

Get license key 9. Contact Sensor Systems, Inc. for a license key and provide them 
with the System ID displayed (703 437-7344).  (Note: If this is a 
field installation the license key should have been shipped with 
the NT system.) 

Enter Key 10. Enter the license key. (See Note for previous step.) 

Exit 11. Exit NeuroActivator research version. 

Remove CD ROM 12. It is safe to remove the installation CD at this point. 
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II. On-Site Configuration 
The following instructions are to be performed by a GE field engineer (FE) at the customer�s 
site.  This will begin with the Windows NT workstation configuration and continue with the 
configuration of NeuroActivator. 

A. On-Site Windows NT TCP\IP Address Assignment 

Advanced Users New Users 

Exit 
NeuroActivator 

1. Move mouse to dismiss the flashing square.  Right click on the image 
of the brain in the lower right hand corner (system tray) and click 
exit. 

Start->Settings-
>Control Panel> 

Network 

2. Launch the WinNT Network configuration utility. Go to Start-
>Settings->Control Panel      (double click �Network� icon) 

Protocols  3.   Select the Protocols tab. 

Select TCP/IP 4.   Select the TCP/IP protocol. 

Properties 5.   Select the Properties button. 

Enter: 

IP Address 

Subnet Mask 

Default Gateway 

6. Assign a static IP address and network configuration settings based 
on   the local network system administrator�s directions.   
Do not select DHCP because a static IP address must be assigned. 
Make note of this IP address since it will be needed to configure 
BrainWave v. 1.x later. 

Ok 7.   Click Ok in the TCP/IP Properties dialog box. 

Ok 8.   Click Ok in the Network dialog box. 

  

B. NeuroActivator Configuration 

Advanced Users   New Users 

Find 
NeuroActivator 
installation 
location 

1.  Use NT Explorer to go to the location where NeuroActivator was 
installed.  Under a standard installation this should be 
C:\ProgramFiles\Sensor Systems, Inc.\NeuroActivator 1.x. 

Find 
NeuroActivator_
Config  or  

NeuroActivator_
Config.exe 

 and  double click 

2.  In the NeuroActivator folder, you will see an icon labeled 
NeuroActivator_Config or NeuroActivator_Config.exe.  Double 
click on this icon to invoke the configuration program. The program 
asks for information about the Host Name, the IP address of the host, 
the Port (i.e., the network connection to the BrainWave console), and 
the local folder path on the PC where the stimulus program will store 
log files for data acquisition sessions. 
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Enter host name 

of the AW 

3.  For Host Name, type in the name of the Solaris machine running AW.  
For example, if this machine is named mrconsole.ge.com, type in 
�mrconsole� as the name. 

Enter IP address 

of the AW 

4.   For IP, type in the IP address of the Solaris machine running AW.  For 
example, if the IP address of this machine is 3.9.27.66, type in 
�3.9.27.66� as the IP address.  Contact the network system admin. for 
this value.  The IP address can also be obtained from the AW console 
window by examining the /etc/hosts file �more /etc/hosts�.  Match the 
line with the hostname of the machine (the second entry of the output 
of �uname �a� is the hostname). 

Set Port to 3000 5.   The port value should be set to 3000 unless there is a higher priority 
device already set to this location.  If you do not use 3000, make note 
of the new number as you will need it to configure BrainWave 
later.  Warning:  Also confirm that there are no other machines 
running NeuroActivator on the same network with the same port 
number. 

Accept default and 
click Save 

6.   Unless there are overriding reasons, you should accept the default 
location for the log files, C:\NeuroActivator\LogFiles. Next, click the 
Save option in the File menu. 

Reboot? � Yes and 
then Exit   

Confirm the icons 

�NeuroActivator� 
and 

�VNC� in the 
lower right- hand 
taskbar 

7.   After clicking the Save option in the File menu, a dialog box will 
appear asking whether to reboot the PC when it exits.  Click on the Yes 
button in the dialog box. Then quit the configuration program by 
selecting Exit under File. The PC will then reboot.   NeuroActivator 
will automatically start and a flashing box will appear.  This �screen-
saver� is displayed to reduce the visual distractions the patient might 
see through the goggles while stimuli are not being delivered.  Input 
from the mouse or keyboard will temporarily de-blank the screen.  
Two icons labeled �NeuroNavigator Stimulus Component� and 
�VNC� will appear in the NT Taskbar.  If both icons do not appear, it 
is likely that the installation failed.  (Note that in rare occasions the 
VNC icon does not always appear even though VNC is installed 
correctly.) 

 8.    For the proper functioning of the BrainWave system, NeuroActivator 
(clinical version) must be running and the flashing box displayed.* 

Continue with 
Section IV. 

Continue the process by going to Section IV to install BrainWave on 
the GE AW system. 

*If you need to gain control of the system, exit NeuroActivator by right-clicking the 
NeuroActivator icon in the system tray (in the right corner of the TaskBar). In the popup menu, 
select Exit to exit NeuroActivator. 
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IV. GE AW BrainWave 

A. BrainWave Installation for Solaris (AW) 

Control/Analysis Module (GE AW 4.0 - UNIX machine)   

Advanced Users  New Users 

Log in sdc 

Tools-> 
Command 
Window 

1.  Log in as sdc and open a command window.  (Browser Tab:  Tools-> 
Command Window) 

The AW system should be idle with no remote users accessing the 
system or trying to send data. 

Insert CD 2.  Load the BrainWave 1.x CD ROM. 

Type easyinstall 

 

3.  Run easyinstall by typing �easyinstall� at the command prompt.  The 
easyinstall installation scripts will guide you through the installation of 
the software. 

Driver: CD-Rom 4. Select Driver: CD-Rom. 

Contents 5. Click the Contents button. 

Install 6. Click the install button. 

Enter license key 7. You will be prompted for the application license key, enter it and hit 
return.  The rest of the installation will proceed automatically.  
Examine the message area for errors.  Possible errors are:  insufficient 
disk space (free up disk space in the $SdC_IMAGE_POOL directory 
and try installing again), invalid license key (try installing again and 
entering the key again or request a new key after checking the system 
information required for key generation is correct). 

Eject CD-ROM 8. Click the Eject CD-ROM button. 

Quit 

Ok 

9. Click the Quit button and then Ok to the reminder 

 

B. BrainWave Configuration for Solaris (AW) 

Advanced Users  New Users 

Security -> 
Restart Software 

More Software-> 
BrainWave 

1.  To test if the installation was successful, shutdown the AW browser and 
restart it (Browser Tab:  Security -> Restart Software). A popup box 
will ask �Do you really want to restart the Software?�.  Click yes.  
Launch BrainWave (Browser Tab:  More Software-> BrainWave.)  
The BrainWave GUI will pop up.  

Main menu 

Manage System 

2.  Configure BrainWave:  Select Main Menu at the bottom of the 
BrainWave GUI.  Then select Manage System.   
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Modify 
Configuration 
Defaults 

Enter password 

Update RTIP path 

3.  Select Modify Configuration Defaults and Set Mode.  Enter a new  
password in the blank space. (i.e. �hello�)  Make note of the password 
you use.  Under the Media Storage tab, check the values of the 
directories.  The default values should be correct unless custom 
modifications have been made to RTC and the location of the RTIP 
database.  Change the entry for the "Advantage Windows RTIP 
Directory" to reflect the local suite name (for example change 'GEM' to 
'USF' in the path).  Note only the first three letters of the suite name are 
used (e.g. �GEM� for suite id name �GEMS�).  It is okay to leave the 
default value for the "BrainWave Database Directory�. 

Stimulus System 

Enter IP address 

Enter Port # - 3000 

4.  Select the Stimulus System tab.  Enter the IP address of the NT 
workstation that is running NeuroActivator (i.e. 192.168.1.55).     
Match this to IP address as Section III,B step 4.  Enter 3000 as the port 
number or match to the number set in Section III,B step 5.  

Dicom 

Hostname 

IP of AW 

Port 

5.  Select the Dicom tab.  Enter the information for the system where 
BrainWave will archive its studies.  Contact the local network system 
administrator for this information.  By default the local AW system is 
selected as is port 4006.  You should enter the hostname and IP of the 
AW system.  Note the default IP address selected is 127.0.0.1 which 
always points to the local machine.  You may want to replace this with 
the actual IP address of the AW workstation.  

Set Defaults 

Main Menu 

6.  Close the Configuration Defaults dialog box by selecting Set Modes 
and Save Config Settings.  Return to the Main Menu. 

Quit BrainWave 

Restart 
BrainWave 

7.  In this menu, quit BrainWave and then restart it by selecting the �more 
software� location and then BrainWave.  

NeuroActivator 
connected - 
confirm 

8.  The BrainWave Messages panel in BrainWave will now display a 
message NeuroActivator connected.  In BrainWave's Manage 
System interface, click on the button labeled Check Status of 
NeuroActivator. The BrainWave Messages panel in BrainWave will 
then display a message NeuroActivator is in idle mode.  If you do 
not see these messages in the BrainWave Messages panel, something 
is wrong with the configuration, NeuroActivator is not currently 
running, or there is a problem with the network. 

Close/exit 9.  Close/exit the UNIX command window.  This is the same location 
where easyinstall was initiated. 
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V. Postscript Printer Setup for use with BrainWave v. 1.x 
This step is run on the AW Solaris Workstation.  Currently only the Codonics color printer is 
supported.  Text after the % should be typed in the command window.  Text in ()�s are 
comments that should not be typed in. 

 

Advanced Users   New Users 

sdc 

Tools-> Command Window 

1.  Log in as sdc and open a command window.  (Browser Tab:  
Tools-> Command Window) 

% su �root 2.  % su �root (you will need to type in the root password for 
the AW workstation) 

% ~sdc/install/install.printers 3.  If you have a printer provided by GE then type  
% ~sdc/install/install.printers 
For other printers skip to step 12 

Return 4.  If you have a Configuration Floppy you should insert it 
now.  Whether you have one or not press [Return] to 
continue ... 

y 5.  Do you want to install new printer(s) [y,n,?,q] y 

GENNavprntr 6.  Define the local name of the printer [?,q] GENNavprntr 
(Note: You must use this printer name) 

Enter selection [?,??,q]: 1 7. Installing Printer 
Printer model 
 1  c    Codonics (1660M 1660MD) 
 2  l     Lexmark (Optra 1650N 1855N SC1275N C710n) 
 3  s    Seiko (1720D) 

Enter selection [?,??,q]: 1 8. Printer Type: 
      1  c    Color printer 
      2  g    Grayscale printer 

Enter IP address 9. Printer internet (IP) address [?,q]  ex. 192.168.1.101 

Enter hostname 10. Printer hostname [?,q]  ex. hp4050n 
              Checking if hp4050n is alive ... 
                   Changing spool directory ... 
              Print services stopped. 
              Changing spool directory ... 
              Print services started. 
                   Removing printer (if necessary) ... 
                   Declaring printer ... 
                   Setting filming configuration file ... 

n 11. Do you want to install new printer(s) [y,n,?,q] n 

Other printers 12. If you have a different printer, follow these steps. 
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sdc 

Tools-> Command Window 

13. Log in as sdc and open a command window.  (Browser   
Tab:  Tools-> Command Window) 

% su �root 14. % su �root (you will need to type in the root password for  
the AW workstation) 

Generic method 15. % lpset -a bsdaddr=<printer_name>,scaled,Solaris    
GENNavprntr 

Example 16. lpset -a bsdaddr=PS_RAD1,scaled,Solaris GENNavprntr 
  
 

This concludes the necessary and optional installation instructions. 
     

VI. Troubleshooting 
 

1. If there are problems with speed of the mouse movement in the NT station window check 
to make sure the display settings have not been changed.  They should be 800x600 and 
256 colors.  Start -> Control Panel -> Display 

2. In general, if you are having problems with connections, be sure that you confer with 
your system administrator to ascertain the correct IP address and the port number.   

3. Take note of the instructions in steps 10 and 12 in Section II,B whereby step 10 concerns 
the INSTALLATION of the WinVNC Service and step 12 concerns the START of the 
program.  

4. Regarding the BrainWave installation on Solaris, if there is an �insufficient disk space� 
message in Section IV,A step 3, free up disk space in the $SdC_IMAGE_POOL directory 
and try installing again.  

5. Again with BrainWave on Solaris, if there is an �invalid license key� message, try to 
install the software again with the same key.  If this doesn�t work, request a new key after 
confirming that the system information required for key generation is correct.  

6. If you find in Section IV, B step 8 that NeuroActivator is NOT connected in the message 
dialog box, repeat step 7 by quitting BrainWave and restarting it.  

 

Contact GE Service Personnel First 
Sensor Systems, Inc. Phone Contact Information  (703) 437-7344 
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Part B - BrainWaveSO Installation 
I. Part B - Introduction 
This part contains the complete installation instructions for Sensor Systems� BrainWaveSO 
software.  The SO version of BrainWaveSO consists of the AW component only. 

 

II. GE AW BrainWaveSO 

A. BrainWaveSO Installation for Solaris (AW) 

Control/Analysis Module (GE AW 4.0 - UNIX machine)   

Advanced Users  New Users 

Log in sdc 

Tools-> 
Command 
Window 

1.  Log in as sdc and open a command window.  (Browser Tab:  Tools-> 
Command Window) 

The AW system should be idle with no remote users accessing the 
system or trying to send data. 

Check for and 
uninstall previous 
versions. 

2.  Check for a previous BrainWave installation.  Type the following in the 
command window: 

 {sdc@aw}[#] cd 

 {sdc@aw}[#] cd sensor (if directory does not exist then skip to step 3) 

 {sdc@aw}[#] ./uninstall.brainwave 

Insert CD 3.  Load the BrainWaveSO 1.x CD ROM. 

Type easyinstall 

 

4.  Run easyinstall by typing �easyinstall� at the command prompt.  The 
easyinstall installation scripts will guide you through the installation of 
the software. 

 {sdc@aw}[#] easyinstall 

Driver: CD-Rom 5. Select Driver: CD-Rom. 

Contents 6. Click the Contents button. 

Install 7. Click the install button. 
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Enter license key 8. You will be prompted for the application license key, enter it and hit 
return.  The rest of the installation will proceed automatically.  
Examine the message area for errors.  Possible errors are:  insufficient 
disk space (free up disk space in the $SdC_IMAGE_POOL directory 
and try installing again), invalid license key (try installing again and 
entering the key again or request a new key after checking the system 
information required for key generation is correct).  Note the 
application license may be also called NeuroNavSO instead of 
BrainWaveSO. 

Eject CD-ROM 9. Click the Eject CD-ROM button. 

Quit 

Ok 

10. Click the Quit button and then Ok to the reminder 

 

B. BrainWaveSO Configuration for Solaris (AW) 

Advanced Users  New Users 

Security -> 
Restart Software 

More Software-> 
BrainWaveSO 

1.  To test if the installation was successful, shutdown the AW browser and 
restart it (Browser Tab:  Security -> Restart Software). A popup box 
will ask �Do you really want to restart the Software?�.  Click yes.  
Launch BrainWaveSO (Browser Tab:  More Software-> 
BrainWaveSO.)  The BrainWaveSO GUI will pop up.  

Main menu 

Manage System 

2.  Configure BrainWaveSO:  Select Main Menu at the bottom of the 
BrainWaveSO GUI if Manage System is not an option.  Select Manage 
System.  For a new installation continue to the next step.  If you have a 
floppy disk with a saved BrainWaveSO configuration (e.g. from a 
previous install) goto Section II-C (of Part B) to restore the setting from 
the floppy disk. 

Modify 
Configuration 
Defaults 

Enter password 

Update RTIP path 

3.  Select Modify Configuration Defaults and Set Mode.  Enter a new  
password in the blank space. (i.e. �hello�)  Make note of the password 
you use.  Under the Media Storage tab, check the values of the 
directories.  The default values should be correct unless custom 
modifications have been made to RTC and the location of the RTIP 
database.  Change the entry for the "Advantage Windows RTIP 
Directory" to reflect the local suite name (for example change 'GEM' to 
'USF' in the path).  Note only the first three letters of the suite name are 
used (e.g. �GEM� for suite id name �GEMS�).  It is okay to leave the 
default value for the "BrainWaveSO Database Directory�. 

Communication 
Port 

Enter Port # - 3000 

4.  Select the Communication Port tab.  Enter 3000 as the port number 
(unless this port number is being used by another application, check 
with the local system administrator if you are in doubt). 

 
15-Oct-02 Made for GE Medical Systems 

GE Rev A Page 16 of 20 

 



Sensor Systems, Inc.   Installation Procedure 

Dicom 

Hostname 

IP of AW 

Port 

5.  Select the Dicom tab.  Enter the information for the system where 
BrainWaveSO will archive its studies.  Contact the local network 
system administrator for this information.  By default the local AW 
system is selected as is port 4006.  You should enter the hostname and 
IP of the AW system.  Note the default IP address selected is 127.0.0.1 
which always points to the local machine.  You may want to replace 
this with the actual IP address of the AW workstation.  

Set Defaults 

Main Menu 

6.  Close the Configuration Defaults dialog box by selecting Set Modes 
and Save Config Settings.  Return to the Main Menu. 

Quit 
BrainWaveSO 

Restart 
BrainWaveSO 

7.  In this menu, quit BrainWaveSO and then restart it by selecting the 
�more software� location and then BrainWaveSO.  

Close/exit 9.  Close/exit the UNIX command window.  This is the same location 
where easyinstall was initiated. 

 

C. BrainWaveSO Save / Restore System Information 

The system information consists of the BrainWaveSO storage directories, communications port, 
and dicom settings as well as the list of Paradigms defined on the system and their color 
associations. 

 

Advanced Users  New Users 

More Software-> 
BrainWaveSO 

1.  Start BrainWaveSO if it is not already running. 

 (Browser Tab:  More Software-> BrainWaveSO.)  The BrainWaveSO 
GUI will pop up.  

Manage System 

Save / Restore � 

Enter password 

2.  Select Manage System. 
Select Save / Restore BrainwWaveSO System Information 
You will be prompted for the service password (see II-B step 3), enter 
it. 

 

Save � 

Ok 

3.  To save the system information to floppy disk select the Save 
Information to Floppy Disk button. 
You will be presented with a confirm box and prompted to insert a 
formatted* floppy disk.  Do so and hit ok.  Once disk activity stops 
eject the disk, label it, and store it in a safe location. 
The files saved are ~sdc/sensor/neuronav/config/NeuroNav.config 
and ~sdc/sensor/nn_db/ParadigmInfoSO.txt 
This saves the communications port, dicom settings, and list of 
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Paradigms and their color associations. 
 
*To format a floppy disk use the following command in a command 
window (unix prompt) : �fdformat �dfv� 

Restore � 

Ok 

Restart 
BrainWaveSO 

4.  To restore the system information from floppy disk select the Restore 
Information from Floppy Disk button.  You will be presented with a 
confirm box and prompted to insert a floppy disk containing previously 
saved system information. 
The files restored are ~sdc/sensor/neuronav/config/NeuroNav.config 
and ~sdc/sensor/nn_db/ParadigmInfoSO.txt.  Backup copies of the files 
currently on disk (if any) will be made with the .bak extension. 
To ensure the settings have taken place exit and restart BrainWaveSO. 
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III. Postscript Printer Setup for use with BrainWaveSO v. 1.x 
This step is run on the AW Solaris Workstation.  Currently only the Codonics color printer is 
supported.  Text after the % should be typed in the command window.  Text in ()�s are 
comments that should not be typed in. 

 

Advanced Users   New Users 

sdc 

Tools-> Command Window 

1.  Log in as sdc and open a command window.  (Browser Tab:  
Tools-> Command Window) 

% su �root 2.  % su �root (you will need to type in the root password for 
the AW workstation) 

% ~sdc/install/install.printers 3.  If you have a printer provided by GE then type  
% ~sdc/install/install.printers 
For other printers skip to step 12 

Return 4.  If you have a Configuration Floppy you should insert it 
now.  Whether you have one or not press [Return] to 
continue ... 

y 5.  Do you want to install new printer(s) [y,n,?,q] y 

GENNavprntr 6.  Define the local name of the printer [?,q] GENNavprntr 
(Note: You must use this printer name) 

Enter selection [?,??,q]: 1 7.  Installing Printer 
Printer model 
 1  c    Codonics (1660M 1660MD) 
 2  l     Lexmark (Optra 1650N 1855N SC1275N C710n) 
 3  s    Seiko (1720D) 

Enter selection [?,??,q]: 1 8.  Printer Type: 
      1  c    Color printer 
      2  g    Grayscale printer 

Enter IP address 9.  Printer internet (IP) address [?,q]  ex. 192.168.1.101 

Enter hostname 10. Printer hostname [?,q]  ex. hp4050n 
              Checking if hp4050n is alive ... 
                   Changing spool directory ... 
              Print services stopped. 
              Changing spool directory ... 
              Print services started. 
                   Removing printer (if necessary) ... 
                   Declaring printer ... 
                   Setting filming configuration file ... 

n 11. Do you want to install new printer(s) [y,n,?,q] n 
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Other printers 12. If you have a different printer, follow these steps. 

sdc 

Tools-> Command Window 

13. Log in as sdc and open a command window.  (Browser   
Tab:  Tools-> Command Window) 

% su �root 14. % su �root (you will need to type in the root password for  
the AW workstation) 

Generic method 15. % lpset -a bsdaddr=<printer_name>,scaled,Solaris    
GENNavprntr 

Example 16. lpset -a bsdaddr=PS_RAD1,scaled,Solaris GENNavprntr 
  
 

This concludes the necessary and optional installation instructions. 
     

IV. Troubleshooting 
 

1. In general, if you are having problems with connections, be sure that you confer with 
your system administrator to ascertain the correct IP address, host names and the port 
number.   

2. Regarding the BrainWaveSO installation on Solaris, if there is an �insufficient disk 
space� message in Section IV,A step 3, free up disk space in the $SdC_IMAGE_POOL 
directory and try installing again.  

3. Again with BrainWaveSO on Solaris, if there is an �invalid license key� message, try to 
install the software again with the same key.  If this doesn�t work, request a new key after 
confirming that the system information required for key generation is correct.  Note:  The 
key may be referred to as NeuroNavSO 

 

Contact GE Service Personnel First 
Sensor Systems, Inc. Phone Contact Information  (703) 437-7344 
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